<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<title>Dems Attacking Their Candidates Over Lack Of Diversity - Liberty News Now</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/cdn-cgi/apps/head/Ci0th4mxVe6IJKG-6nRZdu713KY.js"></script><link rel="pingback" href="https://libertynewsnow.com/xmlrpc.php" />
<meta property="og:image" content="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg" /><link rel="icon" type="image/png" href="/wp-content/uploads/2014/11/favicon.png">

<meta name="description" content="About the cabinet of newly elected President Barack Obama, the Los Angeles Times gushed in 2008: &quot;Seldom has a presidential Cabinet included so..." />
<link rel="canonical" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Dems Attacking Their Candidates Over Lack Of Diversity - Liberty News Now" />
<meta property="og:description" content="About the cabinet of newly elected President Barack Obama, the Los Angeles Times gushed in 2008: &quot;Seldom has a presidential Cabinet included so..." />
<meta property="og:url" content="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680" />
<meta property="og:site_name" content="Liberty News Now" />
<meta property="article:publisher" content="https://www.facebook.com/libertynewsnow" />
<meta property="article:tag" content="2020 election" />
<meta property="article:tag" content="Cory Booker" />
<meta property="article:tag" content="Democratic Debate" />
<meta property="article:tag" content="Diversity" />
<meta property="article:tag" content="Elizabeth Warren" />
<meta property="article:section" content="Elections" />
<meta property="article:published_time" content="2019-12-19T11:00:13+00:00" />
<meta property="article:modified_time" content="2019-12-19T05:05:13+00:00" />
<meta property="og:updated_time" content="2019-12-19T05:05:13+00:00" />
<meta property="fb:app_id" content="1959888430925010" />
<meta property="og:image" content="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg" />
<meta property="og:image:secure_url" content="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="About the cabinet of newly elected President Barack Obama, the Los Angeles Times gushed in 2008: &quot;Seldom has a presidential Cabinet included so..." />
<meta name="twitter:title" content="Dems Attacking Their Candidates Over Lack Of Diversity - Liberty News Now" />
<meta name="twitter:site" content="@LibertyNews_Now" />
<meta name="twitter:image" content="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg" />
<meta name="twitter:creator" content="@LarryElder" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://libertynewsnow.com/","sameAs":["https://www.facebook.com/libertynewsnow","https://www.youtube.com/channel/UCWzWNQkzDkv76nC4GmwDLdg","https://twitter.com/LibertyNews_Now"],"@id":"https://libertynewsnow.com/#organization","name":"Liberty News Now","logo":"https://libertynewsnow.com/wp-content/uploads/2018/04/lnnlogo-R-300x100.png"}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Liberty News Now &raquo; Feed" href="https://libertynewsnow.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Liberty News Now &raquo; Comments Feed" href="https://libertynewsnow.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Liberty News Now &raquo; Dems Attacking Their Candidates Over Lack Of Diversity Comments Feed" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/libertynewsnow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://libertynewsnow.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-newsletter-css' href='https://libertynewsnow.com/wp-content/plugins/td-newsletter/style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://libertynewsnow.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=618b370f2556e74c489bd6592378277f' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css' href='https://libertynewsnow.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://libertynewsnow.com/wp-content/themes/Newspaper/style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://libertynewsnow.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://libertynewsnow.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://libertynewsnow.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://libertynewsnow.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://libertynewsnow.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://libertynewsnow.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://libertynewsnow.com/?p=17680' />
<link rel="alternate" type="application/json+oembed" href="https://libertynewsnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flibertynewsnow.com%2Fdems-attacking-their-candidates-over-lack-of-diversity%2Farticle17680" />
<link rel="alternate" type="text/xml+oembed" href="https://libertynewsnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flibertynewsnow.com%2Fdems-attacking-their-candidates-over-lack-of-diversity%2Farticle17680&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":17680,"post_name":"dems-attacking-their-candidates-over-lack-of-diversity","post_title":"Dems Attacking Their Candidates Over Lack Of Diversity","post_type":"post","post_author":"90","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":708,"name":"Elections","slug":"elections","term_group":0,"term_taxonomy_id":708,"taxonomy":"category","description":"","parent":0,"count":377,"filter":"raw","cat_ID":708,"category_count":377,"category_description":"","cat_name":"Elections","category_nicename":"elections","category_parent":0},{"term_id":2,"name":"Featured","slug":"featured","term_group":0,"term_taxonomy_id":2,"taxonomy":"category","description":"Featured posts","parent":0,"count":4071,"filter":"raw","cat_ID":2,"category_count":4071,"category_description":"Featured posts","cat_name":"Featured","category_nicename":"featured","category_parent":0},{"term_id":5,"name":"Politics","slug":"politics","term_group":0,"term_taxonomy_id":5,"taxonomy":"category","description":"","parent":0,"count":1614,"filter":"raw","cat_ID":5,"category_count":1614,"category_description":"","cat_name":"Politics","category_nicename":"politics","category_parent":0}]; _mmunch['postTags'] = [{"term_id":5763,"name":"2020 election","slug":"2020-election","term_group":0,"term_taxonomy_id":5763,"taxonomy":"post_tag","description":"","parent":0,"count":18,"filter":"raw"},{"term_id":3224,"name":"Cory Booker","slug":"cory-booker","term_group":0,"term_taxonomy_id":3224,"taxonomy":"post_tag","description":"","parent":0,"count":9,"filter":"raw"},{"term_id":7500,"name":"Democratic Debate","slug":"democratic-debate","term_group":0,"term_taxonomy_id":7500,"taxonomy":"post_tag","description":"","parent":0,"count":5,"filter":"raw"},{"term_id":226,"name":"Diversity","slug":"diversity","term_group":0,"term_taxonomy_id":226,"taxonomy":"post_tag","description":"","parent":0,"count":10,"filter":"raw"},{"term_id":134,"name":"Elizabeth Warren","slug":"elizabeth-warren","term_group":0,"term_taxonomy_id":134,"taxonomy":"post_tag","description":"","parent":0,"count":21,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"Larry Elder","ID":90};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mailmunch" data-mailmunch-site-id="491108" async></script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style> <script>
				window.tdwGlobal = {"adminUrl":"https:\/\/libertynewsnow.com\/wp-admin\/","wpRestNonce":"eab272c89d","wpRestUrl":"https:\/\/libertynewsnow.com\/wp-json\/","permalinkStructure":"\/%postname%\/article%post_id%"};
			</script>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://libertynewsnow.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--> <meta name="onesignal" content="wordpress-plugin" />
<link rel="manifest" href="https://libertynewsnow.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://libertynewsnow.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '006e42bf-6fa1-4d1d-9e71-614086e6f020';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://libertynewsnow.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.62c55c8f-4b76-4a2c-bf2b-fd3fb88f056f";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="ca_title" content="Dems Attacking Their Candidates Over Lack Of Diversity" /><meta name="ca_image" content="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-150x150.jpg" /><link rel="amphtml" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680/amp">

<script>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</script>

<style>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</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-6457222518008567",
enable_page_level_ads: true});
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-57182928-2', 'auto');
  ga('send', 'pageview');

</script> <style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

.jp-relatedposts {
    display: none !important;
}

input.wpcf7-form-control.wpcf7-submit:hover {
background-color: #a21e21;
color: #ffffff;
}
input.wpcf7-form-control.wpcf7-submit {
background-color: #be1e2d;
color: #ffffff;
}			</style>

<style>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</style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> <style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-17680 single-format-standard dems-attacking-their-candidates-over-lack-of-diversity global-block-template-1 wpb-js-composer js-comp-ver-5.6 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-td-header-container"><ul id="menu-td-header" class="td-mobile-main-menu"><li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-17"><a href="https://libertynewsnow.com/category/politics">Politics</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://libertynewsnow.com/category/culture">Culture</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://libertynewsnow.com/category/opinion">Opinion</a></li>
<li id="menu-item-1831" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1831"><a href="https://libertynewsnow.com/category/elections">Elections</a></li>
<li id="menu-item-106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-106"><a href="https://libertynewsnow.com/category/video">Video</a></li>
<li id="menu-item-104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104"><a href="https://libertynewsnow.com/contact">Contact</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://libertynewsnow.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<style>
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    </style>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-1 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">
<div>
Thursday, December 19, 2019
</div>
</div>
</div>
<div class="td-header-sp-top-widget">
</div> </div>

</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://libertynewsnow.com/">
<img class="td-retina-data" data-retina="/wp-content/uploads/2014/11/lnnlogo-R-300x100.png" src="/wp-content/uploads/2014/11/lnnlogo.png" alt="Liberty News Now" title="Liberty News Now" />
<span class="td-visual-hidden">Liberty News Now</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header td_uid_1_5dfb8fa6c431a_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="2992647664"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="2992647664"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="2992647664"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="2992647664"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://libertynewsnow.com/">
<img class="td-retina-data" data-retina="/wp-content/uploads/2014/11/lnnlogo-R-300x100.png" src="/wp-content/uploads/2014/11/lnnlogo.png" alt="Liberty News Now" title="Liberty News Now" />
</a>
</div>
<div class="menu-td-header-container"><ul id="menu-td-header-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-17"><a href="https://libertynewsnow.com/category/politics">Politics</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5dfb8fa6c563c_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_2_5dfb8fa6c563c"><script>var block_td_uid_2_5dfb8fa6c563c = new tdBlock();
block_td_uid_2_5dfb8fa6c563c.id = "td_uid_2_5dfb8fa6c563c";
block_td_uid_2_5dfb8fa6c563c.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"5","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_5dfb8fa6c563c_rand","tdc_css_class":"td_uid_2_5dfb8fa6c563c_rand","tdc_css_class_style":"td_uid_2_5dfb8fa6c563c_rand_style"}';
block_td_uid_2_5dfb8fa6c563c.td_column_number = "3";
block_td_uid_2_5dfb8fa6c563c.block_type = "td_block_mega_menu";
block_td_uid_2_5dfb8fa6c563c.post_count = "5";
block_td_uid_2_5dfb8fa6c563c.found_posts = "1614";
block_td_uid_2_5dfb8fa6c563c.header_color = "";
block_td_uid_2_5dfb8fa6c563c.ajax_pagination_infinite_stop = "";
block_td_uid_2_5dfb8fa6c563c.max_num_pages = "323";
tdBlocksArray.push(block_td_uid_2_5dfb8fa6c563c);
</script><div id=td_uid_2_5dfb8fa6c563c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680" rel="bookmark" class="td-image-wrap" title="Dems Attacking Their Candidates Over Lack Of Diversity"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Dems Attacking Their Candidates Over Lack Of Diversity" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680" rel="bookmark" title="Dems Attacking Their Candidates Over Lack Of Diversity">Dems Attacking Their Candidates Over Lack Of Diversity</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-fed-overreaches-with-real-time-payment-systems/article17682" rel="bookmark" class="td-image-wrap" title="The Fed Overreaches With Real-Time Payment Systems"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/overreach-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/overreach-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/overreach-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The Fed Overreaches With Real-Time Payment Systems" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-fed-overreaches-with-real-time-payment-systems/article17682" rel="bookmark" title="The Fed Overreaches With Real-Time Payment Systems">The Fed Overreaches With Real-Time Payment Systems</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/is-trump-acting-guilty/article17681" rel="bookmark" class="td-image-wrap" title="Is Trump Acting Guilty?"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/blame-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/blame-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/blame-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Is Trump Acting Guilty?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/is-trump-acting-guilty/article17681" rel="bookmark" title="Is Trump Acting Guilty?">Is Trump Acting Guilty?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-case-against-socialism/article17674" rel="bookmark" class="td-image-wrap" title="This Is Why Socialism Is A Horrible Idea"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/socialism-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/socialism-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/socialism-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="This Is Why Socialism Is A Horrible Idea" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-case-against-socialism/article17674" rel="bookmark" title="This Is Why Socialism Is A Horrible Idea">This Is Why Socialism Is A Horrible Idea</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/kemps-senate-selection-is-just-identity-politics/article17669" rel="bookmark" class="td-image-wrap" title="Kemp’s Senate Selection is Just Identity Politics"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/identity-politics-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/identity-politics-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/identity-politics-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kemp’s Senate Selection is Just Identity Politics" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/kemps-senate-selection-is-just-identity-politics/article17669" rel="bookmark" title="Kemp’s Senate Selection is Just Identity Politics">Kemp’s Senate Selection is Just Identity Politics</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5dfb8fa6c563c" data-td_block_id="td_uid_2_5dfb8fa6c563c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5dfb8fa6c563c" data-td_block_id="td_uid_2_5dfb8fa6c563c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-18"><a href="https://libertynewsnow.com/category/culture">Culture</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5dfb8fa6ce11f_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_3_5dfb8fa6ce11f"><script>var block_td_uid_3_5dfb8fa6ce11f = new tdBlock();
block_td_uid_3_5dfb8fa6ce11f.id = "td_uid_3_5dfb8fa6ce11f";
block_td_uid_3_5dfb8fa6ce11f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"6","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_3_5dfb8fa6ce11f_rand","tdc_css_class":"td_uid_3_5dfb8fa6ce11f_rand","tdc_css_class_style":"td_uid_3_5dfb8fa6ce11f_rand_style"}';
block_td_uid_3_5dfb8fa6ce11f.td_column_number = "3";
block_td_uid_3_5dfb8fa6ce11f.block_type = "td_block_mega_menu";
block_td_uid_3_5dfb8fa6ce11f.post_count = "5";
block_td_uid_3_5dfb8fa6ce11f.found_posts = "1339";
block_td_uid_3_5dfb8fa6ce11f.header_color = "";
block_td_uid_3_5dfb8fa6ce11f.ajax_pagination_infinite_stop = "";
block_td_uid_3_5dfb8fa6ce11f.max_num_pages = "268";
tdBlocksArray.push(block_td_uid_3_5dfb8fa6ce11f);
</script><div id=td_uid_3_5dfb8fa6ce11f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/corrupting-our-social-norms/article17675" rel="bookmark" class="td-image-wrap" title="Corrupting Our Social Norms"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/socialnorms-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/socialnorms-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/socialnorms-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Corrupting Our Social Norms" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/corrupting-our-social-norms/article17675" rel="bookmark" title="Corrupting Our Social Norms">Corrupting Our Social Norms</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/will-the-secessionist-epidemic-ever-end/article17668" rel="bookmark" class="td-image-wrap" title="Will the Secessionist Epidemic Ever End?"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/brexit-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/brexit-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/brexit-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Will the Secessionist Epidemic Ever End?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/will-the-secessionist-epidemic-ever-end/article17668" rel="bookmark" title="Will the Secessionist Epidemic Ever End?">Will the Secessionist Epidemic Ever End?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/youre-paying-so-students-can-learn-about-queer-arabs/article17664" rel="bookmark" class="td-image-wrap" title="You&#8217;re Paying So Students Can Learn about Queer Arabs"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/queerarabs-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/queerarabs-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/queerarabs-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="You&#8217;re Paying So Students Can Learn about Queer Arabs" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/youre-paying-so-students-can-learn-about-queer-arabs/article17664" rel="bookmark" title="You&#8217;re Paying So Students Can Learn about Queer Arabs">You&#8217;re Paying So Students Can Learn about Queer Arabs</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/greta-thunberg-is-the-perfect-hero-for-an-unserious-time/article17655" rel="bookmark" class="td-image-wrap" title="Greta Thunberg Is the Perfect Hero for an Unserious Time"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/crazy-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/crazy-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/crazy-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Greta Thunberg Is the Perfect Hero for an Unserious Time" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/greta-thunberg-is-the-perfect-hero-for-an-unserious-time/article17655" rel="bookmark" title="Greta Thunberg Is the Perfect Hero for an Unserious Time">Greta Thunberg Is the Perfect Hero for an Unserious Time</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-redemption-of-michael-vick/article17645" rel="bookmark" class="td-image-wrap" title="The Redemption of Michael Vick"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/vick-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/vick-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/vick-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The Redemption of Michael Vick" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-redemption-of-michael-vick/article17645" rel="bookmark" title="The Redemption of Michael Vick">The Redemption of Michael Vick</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5dfb8fa6ce11f" data-td_block_id="td_uid_3_5dfb8fa6ce11f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_3_5dfb8fa6ce11f" data-td_block_id="td_uid_3_5dfb8fa6ce11f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-19"><a href="https://libertynewsnow.com/category/opinion">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5dfb8fa6d6a91_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_4_5dfb8fa6d6a91"><script>var block_td_uid_4_5dfb8fa6d6a91 = new tdBlock();
block_td_uid_4_5dfb8fa6d6a91.id = "td_uid_4_5dfb8fa6d6a91";
block_td_uid_4_5dfb8fa6d6a91.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"7","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_4_5dfb8fa6d6a91_rand","tdc_css_class":"td_uid_4_5dfb8fa6d6a91_rand","tdc_css_class_style":"td_uid_4_5dfb8fa6d6a91_rand_style"}';
block_td_uid_4_5dfb8fa6d6a91.td_column_number = "3";
block_td_uid_4_5dfb8fa6d6a91.block_type = "td_block_mega_menu";
block_td_uid_4_5dfb8fa6d6a91.post_count = "5";
block_td_uid_4_5dfb8fa6d6a91.found_posts = "858";
block_td_uid_4_5dfb8fa6d6a91.header_color = "";
block_td_uid_4_5dfb8fa6d6a91.ajax_pagination_infinite_stop = "";
block_td_uid_4_5dfb8fa6d6a91.max_num_pages = "172";
tdBlocksArray.push(block_td_uid_4_5dfb8fa6d6a91);
</script><div id=td_uid_4_5dfb8fa6d6a91 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/a-snowflakes-christmas-story/article17646" rel="bookmark" class="td-image-wrap" title="A Snowflake’s Christmas Story"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/snowflake-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/snowflake-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/snowflake-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="A Snowflake’s Christmas Story" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/a-snowflakes-christmas-story/article17646" rel="bookmark" title="A Snowflake’s Christmas Story">A Snowflake’s Christmas Story</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/how-long-until-hillary-enters-this-campaign/article17635" rel="bookmark" class="td-image-wrap" title="How Long Until Hillary Enters This Campaign?"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/why-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/why-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/why-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How Long Until Hillary Enters This Campaign?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/how-long-until-hillary-enters-this-campaign/article17635" rel="bookmark" title="How Long Until Hillary Enters This Campaign?">How Long Until Hillary Enters This Campaign?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/trump-indulges-at-the-nato-summit/article17612" rel="bookmark" class="td-image-wrap" title="Trump Indulges At The NATO Summit"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/NATO-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/NATO-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/NATO-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Trump Indulges At The NATO Summit" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/trump-indulges-at-the-nato-summit/article17612" rel="bookmark" title="Trump Indulges At The NATO Summit">Trump Indulges At The NATO Summit</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/i-told-you-obama-was-a-moderate/article17483" rel="bookmark" class="td-image-wrap" title="I Told You Obama Was a Moderate"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/11/headscratcher-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/11/headscratcher-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/11/headscratcher-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="I Told You Obama Was a Moderate" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/i-told-you-obama-was-a-moderate/article17483" rel="bookmark" title="I Told You Obama Was a Moderate">I Told You Obama Was a Moderate</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/lebron-james-is-a-coward/article17405" rel="bookmark" class="td-image-wrap" title="LeBron James Is a Coward"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/10/boooo-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/10/boooo-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/10/boooo-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="LeBron James Is a Coward" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/lebron-james-is-a-coward/article17405" rel="bookmark" title="LeBron James Is a Coward">LeBron James Is a Coward</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5dfb8fa6d6a91" data-td_block_id="td_uid_4_5dfb8fa6d6a91"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_4_5dfb8fa6d6a91" data-td_block_id="td_uid_4_5dfb8fa6d6a91"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-1831"><a href="https://libertynewsnow.com/category/elections">Elections</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_5_5dfb8fa6df3e6_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_5_5dfb8fa6df3e6"><script>var block_td_uid_5_5dfb8fa6df3e6 = new tdBlock();
block_td_uid_5_5dfb8fa6df3e6.id = "td_uid_5_5dfb8fa6df3e6";
block_td_uid_5_5dfb8fa6df3e6.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"708","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_5_5dfb8fa6df3e6_rand","tdc_css_class":"td_uid_5_5dfb8fa6df3e6_rand","tdc_css_class_style":"td_uid_5_5dfb8fa6df3e6_rand_style"}';
block_td_uid_5_5dfb8fa6df3e6.td_column_number = "3";
block_td_uid_5_5dfb8fa6df3e6.block_type = "td_block_mega_menu";
block_td_uid_5_5dfb8fa6df3e6.post_count = "5";
block_td_uid_5_5dfb8fa6df3e6.found_posts = "377";
block_td_uid_5_5dfb8fa6df3e6.header_color = "";
block_td_uid_5_5dfb8fa6df3e6.ajax_pagination_infinite_stop = "";
block_td_uid_5_5dfb8fa6df3e6.max_num_pages = "76";
tdBlocksArray.push(block_td_uid_5_5dfb8fa6df3e6);
</script><div id=td_uid_5_5dfb8fa6df3e6 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680" rel="bookmark" class="td-image-wrap" title="Dems Attacking Their Candidates Over Lack Of Diversity"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Dems Attacking Their Candidates Over Lack Of Diversity" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680" rel="bookmark" title="Dems Attacking Their Candidates Over Lack Of Diversity">Dems Attacking Their Candidates Over Lack Of Diversity</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/is-a-trump-landslide-coming/article17662" rel="bookmark" class="td-image-wrap" title="Is A Trump Landslide Coming?"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/landslide-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/landslide-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/landslide-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Is A Trump Landslide Coming?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/is-a-trump-landslide-coming/article17662" rel="bookmark" title="Is A Trump Landslide Coming?">Is A Trump Landslide Coming?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/biden-claim-could-be-downfall/article17647" rel="bookmark" class="td-image-wrap" title="Biden Claim Could Be Downfall"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/biden-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/biden-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/biden-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Biden Claim Could Be Downfall" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/biden-claim-could-be-downfall/article17647" rel="bookmark" title="Biden Claim Could Be Downfall">Biden Claim Could Be Downfall</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/how-long-until-hillary-enters-this-campaign/article17635" rel="bookmark" class="td-image-wrap" title="How Long Until Hillary Enters This Campaign?"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/why-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/why-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/why-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How Long Until Hillary Enters This Campaign?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/how-long-until-hillary-enters-this-campaign/article17635" rel="bookmark" title="How Long Until Hillary Enters This Campaign?">How Long Until Hillary Enters This Campaign?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-trump-economic-miracle-is-the-best-revenge/article17620" rel="bookmark" class="td-image-wrap" title="The Trump Economic Miracle Is the Best Revenge"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/Revenge-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/Revenge-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/Revenge-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The Trump Economic Miracle Is the Best Revenge" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-trump-economic-miracle-is-the-best-revenge/article17620" rel="bookmark" title="The Trump Economic Miracle Is the Best Revenge">The Trump Economic Miracle Is the Best Revenge</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_5_5dfb8fa6df3e6" data-td_block_id="td_uid_5_5dfb8fa6df3e6"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_5_5dfb8fa6df3e6" data-td_block_id="td_uid_5_5dfb8fa6df3e6"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-106"><a href="https://libertynewsnow.com/category/video">Video</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_6_5dfb8fa6e65ea_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_6_5dfb8fa6e65ea"><script>var block_td_uid_6_5dfb8fa6e65ea = new tdBlock();
block_td_uid_6_5dfb8fa6e65ea.id = "td_uid_6_5dfb8fa6e65ea";
block_td_uid_6_5dfb8fa6e65ea.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_6_5dfb8fa6e65ea_rand","tdc_css_class":"td_uid_6_5dfb8fa6e65ea_rand","tdc_css_class_style":"td_uid_6_5dfb8fa6e65ea_rand_style"}';
block_td_uid_6_5dfb8fa6e65ea.td_column_number = "3";
block_td_uid_6_5dfb8fa6e65ea.block_type = "td_block_mega_menu";
block_td_uid_6_5dfb8fa6e65ea.post_count = "5";
block_td_uid_6_5dfb8fa6e65ea.found_posts = "126";
block_td_uid_6_5dfb8fa6e65ea.header_color = "";
block_td_uid_6_5dfb8fa6e65ea.ajax_pagination_infinite_stop = "";
block_td_uid_6_5dfb8fa6e65ea.max_num_pages = "26";
tdBlocksArray.push(block_td_uid_6_5dfb8fa6e65ea);
</script><div id=td_uid_6_5dfb8fa6e65ea class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/troubleattheborder/article16836" rel="bookmark" class="td-image-wrap" title="Video Captures Amred Cartel Member Leading Illegal Immigrants Across Border"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/06/immigration-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/06/immigration-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/06/immigration-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Video Captures Amred Cartel Member Leading Illegal Immigrants Across Border" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/troubleattheborder/article16836" rel="bookmark" title="Video Captures Amred Cartel Member Leading Illegal Immigrants Across Border">Video Captures Amred Cartel Member Leading Illegal Immigrants Across Border</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/bubblegum-socialism-is-no-laughing-matter/article16484" rel="bookmark" class="td-image-wrap" title="‘Bubblegum Socialism’ Is No Laughing Matter"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/03/sddefault-2-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/03/sddefault-2-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/03/sddefault-2-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="‘Bubblegum Socialism’ Is No Laughing Matter" /><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://libertynewsnow.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video" /></span></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/bubblegum-socialism-is-no-laughing-matter/article16484" rel="bookmark" title="‘Bubblegum Socialism’ Is No Laughing Matter">‘Bubblegum Socialism’ Is No Laughing Matter</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/for-the-people-legislation-is-really-for-the-government/article16448" rel="bookmark" class="td-image-wrap" title="‘For the People’ Legislation is Really ‘For the Government’"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/03/hqdefault-1-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/03/hqdefault-1-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/03/hqdefault-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="‘For the People’ Legislation is Really ‘For the Government’" /><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://libertynewsnow.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video" /></span></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/for-the-people-legislation-is-really-for-the-government/article16448" rel="bookmark" title="‘For the People’ Legislation is Really ‘For the Government’">‘For the People’ Legislation is Really ‘For the Government’</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/twitters-jack-dorsey-squirms-joe-rogan/article16450" rel="bookmark" class="td-image-wrap" title="Twitter&#8217;s Jack Dorsey Squirms for Three Hours on Joe Rogan"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/03/sddefault-1-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/03/sddefault-1-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/03/sddefault-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Twitter&#8217;s Jack Dorsey Squirms for Three Hours on Joe Rogan" /><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://libertynewsnow.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video" /></span></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/twitters-jack-dorsey-squirms-joe-rogan/article16450" rel="bookmark" title="Twitter&#8217;s Jack Dorsey Squirms for Three Hours on Joe Rogan">Twitter&#8217;s Jack Dorsey Squirms for Three Hours on Joe Rogan</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/academic-hoax/article16444" rel="bookmark" class="td-image-wrap" title="The Academic Hoax"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/03/maxresdefault-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/03/maxresdefault-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/03/maxresdefault-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The Academic Hoax" /><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://libertynewsnow.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video" /></span></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/academic-hoax/article16444" rel="bookmark" title="The Academic Hoax">The Academic Hoax</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_5dfb8fa6e65ea" data-td_block_id="td_uid_6_5dfb8fa6e65ea"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_6_5dfb8fa6e65ea" data-td_block_id="td_uid_6_5dfb8fa6e65ea"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-104"><a href="https://libertynewsnow.com/contact">Contact</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://libertynewsnow.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-17680" class="post-17680 post type-post status-publish format-standard has-post-thumbnail hentry category-elections category-featured category-politics tag-2020-election tag-cory-booker tag-democratic-debate tag-diversity tag-elizabeth-warren" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://libertynewsnow.com/category/elections">Elections</a></li><li class="entry-category"><a href="https://libertynewsnow.com/category/politics">Politics</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Dems Attacking Their Candidates Over Lack Of Diversity</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://libertynewsnow.com/author/larryelder">Larry Elder</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2019-12-19T06:00:13+00:00">Dec 19, 2019</time></span> </div>
</header>
</div>
<div class="td-post-sharing-top"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-ps-big td-ps-nogap td-post-sharing-style12 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Flibertynewsnow.com%2Fdems-attacking-their-candidates-over-lack-of-diversity%2Farticle17680">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Dems+Attacking+Their+Candidates+Over+Lack+Of+Diversity&url=https%3A%2F%2Flibertynewsnow.com%2Fdems-attacking-their-candidates-over-lack-of-diversity%2Farticle17680&via=libertynews_now">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680">
<div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
<div class="td-social-but-text">Google+</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680&amp;media=https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg&description=Dems+Attacking+Their+Candidates+Over+Lack+Of+Diversity">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Dems+Attacking+Their+Candidates+Over+Lack+Of+Diversity %0A%0A https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content">
<div class="td-post-featured-image"><a href="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg" data-caption=""><img width="696" height="464" class="entry-thumb td-modal-image" src="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-696x464.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-696x464.jpg 696w, https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-300x200.jpg 300w, https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-768x512.jpg 768w, https://libertynewsnow.com/wp-content/uploads/2019/12/diversity-630x420.jpg 630w, https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg 800w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="diversity" /></a></div>
<div class='mailmunch-forms-before-post' style='display: none !important;'></div><p>About the cabinet of newly elected President Barack Obama, the Los Angeles Times gushed in 2008: &#8220;Seldom has a presidential Cabinet included so many intellectual and political heavyweights. Obama&#8217;s other achievement is to have assembled such an impressive team with due deference to the need for an administration that &#8216;looks like America&#8217; &#8212; Bill Clinton&#8217;s shorthand for ethnic and gender diversity.&#8221;</p>
<p>Sounding the same &#8220;diversity&#8221; theme, former Vice President Joe Biden recently told NPR: &#8220;I have the most diverse staff of anybody running. I&#8217;ve always done that. &#8230; The country has to look like, the administration should look like, the American public.&#8221;</p>
<p>But after Sen. Kamala Harris, D-Calif., dropped out, Democratic president candidate Sen. Cory Booker, D-N.J., complained about the prospect of the next Democratic debate stage with &#8220;no diversity whatsoever.&#8221;</p>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline td_uid_7_5dfb8fa70184f_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="7945591444"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="7945591444"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="7945591444"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="7945591444"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

<p>Booker said on MSNBC: &#8220;I&#8217;m a little angry. I have to say that we started with one of the most diverse fields in our history, giving people pride, and it&#8217;s a damn shame now that the only African American woman in this race, who has been speaking to issues that need to be brought up, is now no longer in it, and we&#8217;re spiraling towards a debate stage that potentially &#8230; could have six people with no diversity whatsoever. The way this is shaping up, especially with the rules of the DNC, it is preferencing millionaires and billionaires and a lot of other things that don&#8217;t ever translate into viability in Iowa.&#8221;</p>
<p>&#8220;Giving people pride&#8221;?</p>
<p>If Booker is referring to blacks, lack of self-esteem is hardly the problem. As conservative columnist Dinesh D&#8217;Souza points out, &#8220;Several studies have shown that, within the U.S., black males have the highest self-esteem of any group.&#8221; In an article called &#8220;Black Women Are More Confident Than Any Other Group of Females,&#8221; Glamour Magazine quoted San Diego State University psychology professor Jean Twenge, who says, &#8220;Research shows black women score higher on self-esteem than women of other races and ethnicities, which may seem surprising, given the long history of prejudice and discrimination they have faced.&#8221;</p>
<p>As for Booker&#8217;s &#8220;no diversity whatsoever&#8221; complaint, he is effectively accusing the Democratic caucus and primary voters, responsible for choosing their nominee, of both racism <em>and</em> sexism for their rejection of Harris. Shortly before her withdrawal, she attributed her falling poll numbers to a lack of &#8220;electability&#8221; due to sexism and racism.</p>
<p>&#8220;Why is that?&#8221; a reporter asked her. Harris responded: &#8220;Electability. You know, essentially, is America ready for a woman and a woman of color to be president of the United States?&#8221;<br />
At the time of Booker&#8217;s complaint, the six Democrats likely to make the next debate were Joe Biden, Bernie Sanders, Amy Klobuchar, Pete Buttigieg, Elizabeth Warren and Tom Steyer. Let&#8217;s examine their alleged lack of diversity:</p>
<p>Joe Biden would become only the second Catholic president, after John F. Kennedy, who was elected almost 60 years ago.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<p>Bernie Sanders&#8217; father was an immigrant from what is now Poland. His maternal grandparents are from Russia and Poland. If nominated and elected, Sanders would become the first Jewish president.</p>
<p>Amy Klobuchar&#8217;s maternal grandparents immigrated from Switzerland, and her father&#8217;s grandparents immigrated from Slovenia. Winning the presidency would, of course, make Klobuchar the first female president.</p>
<p>Pete Buttigieg is an openly gay Episcopalian man married to a man. His father immigrated from Malta. Buttigieg would become the first gay president and, at age 39 by the time he would take office, the youngest president ever elected.</p>
<p>Elizabeth Warren, a Methodist, no longer calls herself a Native American. So that box cannot be checked off. But she remains a female in a country that has never elected a female president or vice president.</p>
<p>Tom Steyer was the last-hour billionaire entrant into the race. His father was a nonpracticing Jew, and his mother was a Episcopalian, as is Tom. &#8220;My parents&#8217; house was not particularly religious,&#8221; Steyer said. &#8220;They had different religions. My father was brought up Jewish; he was quite irreligious. &#8230; My mother was quite religious.&#8221;</p>
<p>That&#8217;s not enough diversity? And, since Booker&#8217;s complaint about the lack of diversity, former tech entrepreneur Andrew Yang, a Chinese-American, has qualified for the next debate. But no blacks. This means these seven debaters, despite having diverse religions, income levels, backgrounds, upbringings and heritage, flat-out flunk the party&#8217;s diversity test.</p>
<p>&#8220;Woke&#8221; Democrats like Booker have either forgotten or no longer embrace the words of Rev. Martin Luther King Jr., who in 1963 delivered one of the most famous speeches in American history in front of the Lincoln Memorial in Washington, D.C., before an estimated crowd of 250,000. King said, &#8220;I have a dream that my four little children will one day live in a nation where they will not be judged by the color of their skin, but by the content of their character.&#8221;</p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-17680" class="share-facebook sd-button share-icon no-text" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-17680" class="share-twitter sd-button share-icon no-text" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-17680" class="share-pinterest sd-button share-icon no-text" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class="td-a-rec td-a-rec-id-content_bottom  td_uid_8_5dfb8fa701b19_rand td_block_template_1">
<div id="contentad392316"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "2f0fc4cd-85a2-426a-afae-fd798995bf3a",
            d: "bGliZXJ0eW5ld3Nub3cuY29t",
            wid: "392316",
            cb: (new Date()).getTime()
        };
        var qs = Object.keys(params).reduce(function(a, k){ a.push(k + '=' + encodeURIComponent(params[k])); return a},[]).join(String.fromCharCode(38));
        var s = d.createElement('script'); s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs;
        d.getElementById("contentad392316").appendChild(s);
    })(document);
</script></div> </div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="author-box-wrap"><a href="https://libertynewsnow.com/author/larryelder"><img src="https://libertynewsnow.com/wp-content/uploads/2019/01/larry-elder-150x150.jpg" width="96" height="96" alt="Larry Elder" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://libertynewsnow.com/author/larryelder">Larry Elder</a></span></div><div class="td-author-description">Larry Elder is a best-selling author and nationally syndicated radio talk show host. To find out more about Larry Elder, or become an "Elderado," visit www.LarryElder.com.</div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://twiter.com/LarryElder" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Larry Elder"></span><meta itemprop="datePublished" content="2019-12-19T06:00:13+00:00"><meta itemprop="dateModified" content="2019-12-19T00:05:13-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://libertynewsnow.com/dems-attacking-their-candidates-over-lack-of-diversity/article17680" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="/wp-content/uploads/2014/11/lnnlogo.png"></span><meta itemprop="name" content="Liberty News Now"></span><meta itemprop="headline " content="Dems Attacking Their Candidates Over Lack Of Diversity"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://libertynewsnow.com/wp-content/uploads/2019/12/diversity.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="533"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts td_uid_9_5dfb8fa7035bb_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_9_5dfb8fa7035bb"><script>var block_td_uid_9_5dfb8fa7035bb = new tdBlock();
block_td_uid_9_5dfb8fa7035bb.id = "td_uid_9_5dfb8fa7035bb";
block_td_uid_9_5dfb8fa7035bb.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"td_uid_9_5dfb8fa7035bb_rand","td_column_number":3,"live_filter_cur_post_id":17680,"live_filter_cur_post_author":"90","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_9_5dfb8fa7035bb_rand","tdc_css_class_style":"td_uid_9_5dfb8fa7035bb_rand_style"}';
block_td_uid_9_5dfb8fa7035bb.td_column_number = "3";
block_td_uid_9_5dfb8fa7035bb.block_type = "td_block_related_posts";
block_td_uid_9_5dfb8fa7035bb.post_count = "3";
block_td_uid_9_5dfb8fa7035bb.found_posts = "53";
block_td_uid_9_5dfb8fa7035bb.header_color = "";
block_td_uid_9_5dfb8fa7035bb.ajax_pagination_infinite_stop = "";
block_td_uid_9_5dfb8fa7035bb.max_num_pages = "18";
tdBlocksArray.push(block_td_uid_9_5dfb8fa7035bb);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_10_5dfb8fa7058b7" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_9_5dfb8fa7035bb" href="#">RELATED ARTICLES</a><a id="td_uid_11_5dfb8fa7058c1" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_9_5dfb8fa7035bb" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_9_5dfb8fa7035bb class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-trump-economic-miracle-is-the-best-revenge/article17620" rel="bookmark" class="td-image-wrap" title="The Trump Economic Miracle Is the Best Revenge"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/Revenge-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/Revenge-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/Revenge-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The Trump Economic Miracle Is the Best Revenge" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-trump-economic-miracle-is-the-best-revenge/article17620" rel="bookmark" title="The Trump Economic Miracle Is the Best Revenge">The Trump Economic Miracle Is the Best Revenge</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/democrats-diversity-only-in-the-back-of-the-bus/article17618" rel="bookmark" class="td-image-wrap" title="Democrats&#8217; Diversity &#8212; Only in the Back of the Bus"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/whitewash-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/whitewash-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/whitewash-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Democrats&#8217; Diversity &#8212; Only in the Back of the Bus" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/democrats-diversity-only-in-the-back-of-the-bus/article17618" rel="bookmark" title="Democrats&#8217; Diversity &#8212; Only in the Back of the Bus">Democrats&#8217; Diversity &#8212; Only in the Back of the Bus</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/democrats-in-trouble-time-to-hit-panic-button/article17598" rel="bookmark" class="td-image-wrap" title="Democrats In Trouble&#8230; Time To Hit Panic Button"><img width="218" height="150" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/panicbutton-218x150.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/panicbutton-218x150.jpg 218w, https://libertynewsnow.com/wp-content/uploads/2019/12/panicbutton-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Democrats In Trouble&#8230; Time To Hit Panic Button" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/democrats-in-trouble-time-to-hit-panic-button/article17598" rel="bookmark" title="Democrats In Trouble&#8230; Time To Hit Panic Button">Democrats In Trouble&#8230; Time To Hit Panic Button</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_9_5dfb8fa7035bb" data-td_block_id="td_uid_9_5dfb8fa7035bb"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_9_5dfb8fa7035bb" data-td_block_id="td_uid_9_5dfb8fa7035bb"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div id="disqus_thread"></div>
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>DON&#8217;T LET THE MEDIA CONTROL YOU</span></h4> <div class="textwidget"><p>Stay up to date with the latest political news and non-partisan opinion on issues that impact our liberty and receive the latest news and offers from our sponsors.</p>
<div role="form" class="wpcf7" id="wpcf7-f3082-p17680-o1" lang="en-US" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/dems-attacking-their-candidates-over-lack-of-diversity/article17680#wpcf7-f3082-p17680-o1" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="3082" />
<input type="hidden" name="_wpcf7_version" value="5.1.3" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f3082-p17680-o1" />
<input type="hidden" name="_wpcf7_container_post" value="17680" />
<input type="hidden" name="g-recaptcha-response" value="" />
</div>
<p><span class="wpcf7-form-control-wrap email"><input type="email" name="email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" placeholder="Email" /></span></p>
<p><input type="submit" value="Sign Up" class="wpcf7-form-control wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div>
</div>
</aside>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar td_uid_12_5dfb8fa708cac_rand td_block_template_1 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="9146389533"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="9146389533"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="9146389533"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6457222518008567" data-ad-slot="9146389533"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

<div class="td_block_wrap td_block_7 td_block_widget td_uid_13_5dfb8fa709079_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding" data-td-block-uid="td_uid_13_5dfb8fa709079"><script>var block_td_uid_13_5dfb8fa709079 = new tdBlock();
block_td_uid_13_5dfb8fa709079.id = "td_uid_13_5dfb8fa709079";
block_td_uid_13_5dfb8fa709079.atts = '{"custom_title":"Popular Stories","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m6_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"2","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_7_day","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_13_5dfb8fa709079_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_13_5dfb8fa709079_rand","tdc_css_class_style":"td_uid_13_5dfb8fa709079_rand_style"}';
block_td_uid_13_5dfb8fa709079.td_column_number = "1";
block_td_uid_13_5dfb8fa709079.block_type = "td_block_7";
block_td_uid_13_5dfb8fa709079.post_count = "3";
block_td_uid_13_5dfb8fa709079.found_posts = "17";
block_td_uid_13_5dfb8fa709079.header_color = "#";
block_td_uid_13_5dfb8fa709079.ajax_pagination_infinite_stop = "";
block_td_uid_13_5dfb8fa709079.max_num_pages = "6";
tdBlocksArray.push(block_td_uid_13_5dfb8fa709079);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Popular Stories</span></h4></div><div id=td_uid_13_5dfb8fa709079 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-redemption-of-michael-vick/article17645" rel="bookmark" class="td-image-wrap" title="The Redemption of Michael Vick"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/vick-100x70.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/vick-100x70.jpg 100w, https://libertynewsnow.com/wp-content/uploads/2019/12/vick-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Redemption of Michael Vick" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-redemption-of-michael-vick/article17645" rel="bookmark" title="The Redemption of Michael Vick">The Redemption of Michael Vick</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-12T05:00:08+00:00">Dec 12, 2019</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/biden-claim-could-be-downfall/article17647" rel="bookmark" class="td-image-wrap" title="Biden Claim Could Be Downfall"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/biden-100x70.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/biden-100x70.jpg 100w, https://libertynewsnow.com/wp-content/uploads/2019/12/biden-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Biden Claim Could Be Downfall" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/biden-claim-could-be-downfall/article17647" rel="bookmark" title="Biden Claim Could Be Downfall">Biden Claim Could Be Downfall</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-12T06:00:12+00:00">Dec 12, 2019</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/house-democrat-impeachment-rules-are-made-for-a-lynch-mob/article17652" rel="bookmark" class="td-image-wrap" title="House Democrat Impeachment Rules Are Made For A Lynch Mob"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/house-100x70.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/house-100x70.jpg 100w, https://libertynewsnow.com/wp-content/uploads/2019/12/house-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="House Democrat Impeachment Rules Are Made For A Lynch Mob" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/house-democrat-impeachment-rules-are-made-for-a-lynch-mob/article17652" rel="bookmark" title="House Democrat Impeachment Rules Are Made For A Lynch Mob">House Democrat Impeachment Rules Are Made For A Lynch Mob</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-13T04:00:51+00:00">Dec 13, 2019</time></span> </div>
</div>
</div>
</div> </div></div> <aside class="td_block_template_1 widget content-ad-widget">
<div id="contentad35733"></div>
</aside><div class="td-a-rec td-a-rec-id-custom_ad_2  td_uid_14_5dfb8fa712036_rand td_block_template_1"><div id="rcjsload_c904b1"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer||""==referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcds = document.getElementById("rcjsload_c904b1");
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w=44167&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
rcds.appendChild(rcel);


})();
</script></div><div class="td_block_wrap td_block_7 td_block_widget td_uid_15_5dfb8fa712304_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding" data-td-block-uid="td_uid_15_5dfb8fa712304"><script>var block_td_uid_15_5dfb8fa712304 = new tdBlock();
block_td_uid_15_5dfb8fa712304.id = "td_uid_15_5dfb8fa712304";
block_td_uid_15_5dfb8fa712304.atts = '{"custom_title":"Editor\u0027s Choice","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"Editor\u0027s Choice","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_15_5dfb8fa712304_rand","separator":"","m6_tl":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_15_5dfb8fa712304_rand","tdc_css_class_style":"td_uid_15_5dfb8fa712304_rand_style"}';
block_td_uid_15_5dfb8fa712304.td_column_number = "1";
block_td_uid_15_5dfb8fa712304.block_type = "td_block_7";
block_td_uid_15_5dfb8fa712304.post_count = "3";
block_td_uid_15_5dfb8fa712304.found_posts = "1032";
block_td_uid_15_5dfb8fa712304.header_color = "#";
block_td_uid_15_5dfb8fa712304.ajax_pagination_infinite_stop = "";
block_td_uid_15_5dfb8fa712304.max_num_pages = "344";
tdBlocksArray.push(block_td_uid_15_5dfb8fa712304);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Editor&#039;s Choice</span></h4></div><div id=td_uid_15_5dfb8fa712304 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-real-problem-with-immigration-policy-judges/article16584" rel="bookmark" class="td-image-wrap" title="The Surprising Problem With Our Immigration Policy"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/04/judges-100x70.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/04/judges-100x70.jpg 100w, https://libertynewsnow.com/wp-content/uploads/2019/04/judges-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="judges" title="The Surprising Problem With Our Immigration Policy" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-real-problem-with-immigration-policy-judges/article16584" rel="bookmark" title="The Surprising Problem With Our Immigration Policy">The Surprising Problem With Our Immigration Policy</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-04-12T07:00:23+00:00">Apr 12, 2019</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-fake-news-surge-in-hate-crimes/article16577" rel="bookmark" class="td-image-wrap" title="The Fake News &#8216;Surge&#8217; in Hate Crimes"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/04/fake-news-100x70.png" srcset="https://libertynewsnow.com/wp-content/uploads/2019/04/fake-news-100x70.png 100w, https://libertynewsnow.com/wp-content/uploads/2019/04/fake-news-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="fake news" title="The Fake News &#8216;Surge&#8217; in Hate Crimes" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-fake-news-surge-in-hate-crimes/article16577" rel="bookmark" title="The Fake News &#8216;Surge&#8217; in Hate Crimes">The Fake News &#8216;Surge&#8217; in Hate Crimes</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-04-11T12:58:13+00:00">Apr 11, 2019</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/ilhan-omar-its-all-about-the-ad-hominems-baby/article16483" rel="bookmark" class="td-image-wrap" title="Ilhan Omar: It&#8217;s All About the Ad Hominems, Baby"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/02/omar-100x70.png" srcset="https://libertynewsnow.com/wp-content/uploads/2019/02/omar-100x70.png 100w, https://libertynewsnow.com/wp-content/uploads/2019/02/omar-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Rep Ilhan Omar censored as anti-semitic" title="Ilhan Omar: It&#8217;s All About the Ad Hominems, Baby" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/ilhan-omar-its-all-about-the-ad-hominems-baby/article16483" rel="bookmark" title="Ilhan Omar: It&#8217;s All About the Ad Hominems, Baby">Ilhan Omar: It&#8217;s All About the Ad Hominems, Baby</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-03-13T21:21:41+00:00">Mar 13, 2019</time></span> </div>
</div>
</div>
</div> </div></div> <div class="td-a-rec td-a-rec-id-custom_ad_1  td_uid_16_5dfb8fa718aaf_rand td_block_template_1"><script id="spout-tag-3161897d-cfa7-4eb6-bd0b-ac39190df9c7">
  (function() {
    var r = encodeURIComponent(top.document.referrer.substring(0,250)),
        p = encodeURIComponent(top.document.location.href.substring(0,250)),
        t = Date.now(),
        u = '3161897d-cfa7-4eb6-bd0b-ac39190df9c7',
        e = document.createElement('script'),
        s = sessionStorage.getItem('spoutable-' + u);
    if (!s) {
      var m = Math.random.bind(Math);
      s = JSON.stringify({ sessionId: [ t, m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m() ]});
      sessionStorage.setItem('spoutable-' + u, s);
    }
    e.async = true;
    e.src='//s.spoutable.com/s?u='+u+'&s='+encodeURIComponent(s)+'&t='+t+'&r='+r+'&p='+p;
    document.head.appendChild(e);
  })();
</script></div> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-container-wrap td-footer-template-9 ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_media_image"><img class="image " src="/wp-content/uploads/2014/11/lnnlogo.png" alt="" width="300" height="100" /></aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p>Covering the policies and culture that impact our liberty with the latest political news and non-partisan opinion.</p>
<p>Liberty News Now is a member of the Media Bridge Network.</p>
<p>Contact us: <a href="/cdn-cgi/l/email-protection#f0b99e969fb0bc999295828489be958783be9f87de939f9d"><span class="__cf_email__" data-cfemail="c38aada5ac838faaa1a6b1b7ba8da6b4b08dacb4eda0acae">[email&#160;protected]</span></a></p>
</div>
</aside> </div>
<div class="td-pb-span4">
<div class="td_block_wrap td_block_7 td_block_widget td_uid_18_5dfb8fa719578_rand td-pb-border-top td_block_template_10 td-column-1 td_block_padding" data-td-block-uid="td_uid_18_5dfb8fa719578"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_td_uid_18_5dfb8fa719578 = new tdBlock();
block_td_uid_18_5dfb8fa719578.id = "td_uid_18_5dfb8fa719578";
block_td_uid_18_5dfb8fa719578.atts = '{"custom_title":"Don\u0027t Miss","custom_url":"","block_template_id":"td_block_template_10","header_text_color":"#","border_color":"#","accent_text_color":"#","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"2","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_7_day","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_18_5dfb8fa719578_rand","separator":"","m6_tl":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_18_5dfb8fa719578_rand","tdc_css_class_style":"td_uid_18_5dfb8fa719578_rand_style"}';
block_td_uid_18_5dfb8fa719578.td_column_number = "1";
block_td_uid_18_5dfb8fa719578.block_type = "td_block_7";
block_td_uid_18_5dfb8fa719578.post_count = "3";
block_td_uid_18_5dfb8fa719578.found_posts = "17";
block_td_uid_18_5dfb8fa719578.header_color = "";
block_td_uid_18_5dfb8fa719578.ajax_pagination_infinite_stop = "";
block_td_uid_18_5dfb8fa719578.max_num_pages = "6";
tdBlocksArray.push(block_td_uid_18_5dfb8fa719578);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Don&#039;t Miss</span></h4></div><div id=td_uid_18_5dfb8fa719578 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/the-redemption-of-michael-vick/article17645" rel="bookmark" class="td-image-wrap" title="The Redemption of Michael Vick"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/vick-100x70.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/vick-100x70.jpg 100w, https://libertynewsnow.com/wp-content/uploads/2019/12/vick-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Redemption of Michael Vick" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/the-redemption-of-michael-vick/article17645" rel="bookmark" title="The Redemption of Michael Vick">The Redemption of Michael Vick</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-12T05:00:08+00:00">Dec 12, 2019</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/biden-claim-could-be-downfall/article17647" rel="bookmark" class="td-image-wrap" title="Biden Claim Could Be Downfall"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/biden-100x70.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/biden-100x70.jpg 100w, https://libertynewsnow.com/wp-content/uploads/2019/12/biden-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Biden Claim Could Be Downfall" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/biden-claim-could-be-downfall/article17647" rel="bookmark" title="Biden Claim Could Be Downfall">Biden Claim Could Be Downfall</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-12T06:00:12+00:00">Dec 12, 2019</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://libertynewsnow.com/house-democrat-impeachment-rules-are-made-for-a-lynch-mob/article17652" rel="bookmark" class="td-image-wrap" title="House Democrat Impeachment Rules Are Made For A Lynch Mob"><img width="100" height="70" class="entry-thumb" src="https://libertynewsnow.com/wp-content/uploads/2019/12/house-100x70.jpg" srcset="https://libertynewsnow.com/wp-content/uploads/2019/12/house-100x70.jpg 100w, https://libertynewsnow.com/wp-content/uploads/2019/12/house-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="House Democrat Impeachment Rules Are Made For A Lynch Mob" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://libertynewsnow.com/house-democrat-impeachment-rules-are-made-for-a-lynch-mob/article17652" rel="bookmark" title="House Democrat Impeachment Rules Are Made For A Lynch Mob">House Democrat Impeachment Rules Are Made For A Lynch Mob</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-13T04:00:51+00:00">Dec 13, 2019</time></span> </div>
</div>
</div>
</div> </div></div>  </div>
<div class="td-pb-span4">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget">
</div>
</aside><div class="td_block_wrap td_block_popular_categories td_block_widget td_uid_19_5dfb8fa72114b_rand widget widget_categories td-pb-border-top td_block_template_10" data-td-block-uid="td_uid_19_5dfb8fa72114b"><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Quick Nav</span></h4></div><ul class="td-pb-padding-side"><li><a href="https://libertynewsnow.com/category/politics"><span class="td-cat-name">Politics</span><span class="td-cat-no">1614</span></a></li><li><a href="https://libertynewsnow.com/category/culture"><span class="td-cat-name">Culture</span><span class="td-cat-no">1339</span></a></li><li><a href="https://libertynewsnow.com/category/opinion"><span class="td-cat-name">Opinion</span><span class="td-cat-no">858</span></a></li><li><a href="https://libertynewsnow.com/category/slideshow"><span class="td-cat-name">Slideshow</span><span class="td-cat-no">694</span></a></li><li><a href="https://libertynewsnow.com/category/crime"><span class="td-cat-name">Crime</span><span class="td-cat-no">481</span></a></li><li><a href="https://libertynewsnow.com/category/elections"><span class="td-cat-name">Elections</span><span class="td-cat-no">377</span></a></li></ul></div>  </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-td_demo_footer-container"><ul id="menu-td_demo_footer" class="td-subfooter-menu"><li id="menu-item-12" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-12"><a href="/contact">Advertising</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-114"><a href="https://libertynewsnow.com/privacy">We Respect Your Privacy</a></li>
<li id="menu-item-115" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-115"><a href="https://libertynewsnow.com/contact">Contact Us</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Copyright 2015-2019 - Liberty News Now </div>
</div>
</div>
</div>
</div>

<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/libertynewsnow.com\/dems-attacking-their-candidates-over-lack-of-diversity\/article17680":17680};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/libertynewsnow.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"libertynn"};
/* ]]> */
</script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"17680 https:\/\/libertynewsnow.com\/?p=17680","disqusShortname":"libertynn","disqusTitle":"Dems Attacking Their Candidates Over Lack Of Diversity","disqusUrl":"https:\/\/libertynewsnow.com\/dems-attacking-their-candidates-over-lack-of-diversity\/article17680","postId":"17680"};
/* ]]> */
</script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201951'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LfEpZcUAAAAAD2nDimzo7zsqJiltjMYYn8rjvfM&#038;ver=3.0'></script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.5'></script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-includes/js/comment-reply.min.js?ver=5.1.4'></script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-includes/js/wp-embed.min.js?ver=5.1.4'></script>
<script type='text/javascript' src='//api.content-ad.net/Scripts/widget2.aspx?id=ea33c731-5138-414b-97bf-c8c612d1d0c5&#038;d=bGliZXJ0eW5ld3Nub3cuY29t&#038;wid=35733&#038;cb=1.57676739907E%2B12&#038;ver=1.3.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://libertynewsnow.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.9.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type="text/javascript">
( function( grecaptcha, sitekey, actions ) {

	var wpcf7recaptcha = {

		execute: function( action ) {
			grecaptcha.execute(
				sitekey,
				{ action: action }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		},

		executeOnHomepage: function() {
			wpcf7recaptcha.execute( actions[ 'homepage' ] );
		},

		executeOnContactform: function() {
			wpcf7recaptcha.execute( actions[ 'contactform' ] );
		},

	};

	grecaptcha.ready(
		wpcf7recaptcha.executeOnHomepage
	);

	document.addEventListener( 'change',
		wpcf7recaptcha.executeOnContactform, false
	);

	document.addEventListener( 'wpcf7submit',
		wpcf7recaptcha.executeOnHomepage, false
	);

} )(
	grecaptcha,
	'6LfEpZcUAAAAAD2nDimzo7zsqJiltjMYYn8rjvfM',
	{"homepage":"homepage","contactform":"contactform"}
);
</script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://libertynewsnow.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://libertynewsnow.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201951.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'79959285',post:'17680',tz:'-5',srv:'libertynewsnow.com'} ]);
	_stq.push([ 'clickTrackerInit', '79959285', '17680' ]);
</script>
<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
<header>
<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
</header>
<div class="tdw-content">
<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">
<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>
<textarea class="tdw-css-writer-editor td_live_css_uid_1_5dfb8fa725ff5"></textarea>
<div id="td_live_css_uid_1_5dfb8fa725ff5" class="td-code-editor"></div>
<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5dfb8fa725ff5');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5dfb8fa725ff5");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>
</div>
</div>
<footer>
<a href="#" class="tdw-save-css">Save</a>
<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>
<div class="tdw-resize"></div>
</footer>
</div>
</body>
</html>